Englischen TS-Stream in mpeg konvertiert - kein Ton!

Antworten
Loko444
Beiträge: 8
Registriert: 23.05.2011, 22:27

Englischen TS-Stream in mpeg konvertiert - kein Ton!

Beitrag von Loko444 » 23.05.2011, 22:37

Hallo Zusammen,

ich besitze den Kathrein UFS 922 Receiver. Ich habe einen Stream vom englischen Musikkanal "DanceNation" vorliegen. Diesen versuche ich mit DVR Studio HD 2.17 nach mpeg zu konvertieren (mit Schnitt). Ich hab alle Audio Decoder für MPEG schon durch, aber das konvertierte MPEG Video spielt keinen Ton ab! Auch hab ich ffdschow Audio Decoder installiert, bringt auch nix.

Wo liegt hier das Problem? Kann mir jemand weiterhelfen?



Kurze Info noch zu dem Stream: Lt. Angaben von DVR-Studio HD 2.17 unten links im Informationsmenue des geöffneten Projekts (Streams) sehe ich folgende Infos:

MPEG-2 544x576i, 16:9
Sende-Raster: 0,5 s; Datenrate: 2,1 Mbit/s
MPEG Stereo 192 kBit/s (undefined)

Ich freue mich auf Hilfe.

Viele Grüße,
Loko
Benutzeravatar
Ralf
Inhaber HS
Beiträge: 10438
Registriert: 13.08.2005, 15:23

Beitrag von Ralf » 24.05.2011, 08:22

Hallo Loko444,

wenn ich es richtig lese, so hat die exportierte in einem anderen Player keinen Ton. Ist der Ton in DVR-Studio HD denn da?

Die Codecs in DVR-Studio HD sind nur für die interne Wiedergabe und haben keinen Einfluss auf das exportierte Ergebnis.

Sollte es in DVR-Studio HD bei anderen Sendern Ton haben und nur bei dem Sender nicht, so brauchen wir von dem mal eine 20MB Testdatei.
Bitte erstelle mit DVR-Studio HD eine Supportanfrage.
Wie das geht ist hier ausführlich beschrieben:
viewtopic.php?t=3718
Mit freundlichen Grüßen

Ralf

Gehe zu Facebook...
Über ein “Like” würden wir uns sehr freuen.
Bild
Loko444
Beiträge: 8
Registriert: 23.05.2011, 22:27

Beitrag von Loko444 » 25.05.2011, 14:24

Ralf hat geschrieben:Hallo Loko444,

wenn ich es richtig lese, so hat die exportierte in einem anderen Player keinen Ton. Ist der Ton in DVR-Studio HD denn da?

Die Codecs in DVR-Studio HD sind nur für die interne Wiedergabe und haben keinen Einfluss auf das exportierte Ergebnis.

Sollte es in DVR-Studio HD bei anderen Sendern Ton haben und nur bei dem Sender nicht, so brauchen wir von dem mal eine 20MB Testdatei.
Bitte erstelle mit DVR-Studio HD eine Supportanfrage.
Wie das geht ist hier ausführlich beschrieben:
viewtopic.php?t=3718
Hallo Ralf, danke für deine Antwort.

Genau: Ich habe den englischen TS-Stream geschnitten und in MPEG exportiert. Dann hat dieses exportierte MPEG-Video in keinem externen Player bei mir Ton abgegeben (VCL und Windows Media Player). In DVR-Studio HD dagegen ist der Ton da, wenn ich den originalen englischen TS-Stream abspiele.
TS-Streams von anderen Sendern (z.B. Pro7) werden ohne Probleme geschnitten und von TS- in MPEG exportiert, also Video MIT Ton.

Ich habe soeben eine Supportanfrage abgeschlossen. Wichtiger Hinweis: Ich hatte eine 20 MByte Datei des Streams mit abgeschickt, aber das mir vorliegende Problem nicht nachproduzieren können. Grund ist, dass mir die Software DVR Studio HD 2.17 beim nach dem Schneiden, dem exportierten TS-Stream in MPEG, und nach dem Versuch des Speicherns dieses vorliegenden Schnitts mitteilte, dass mein Ausgabeverzeichnis voll sei. Ich solle Platz schaffen oder unter Einstellungen einen entsprechenden Speicherort für die zu exportierende Datei schaffen. Aber ich besitze über genügend Festplattenspeicher. Hab verschiedene Ausgabeorte vergeblich versucht. Das scheint bei euch ein Programmfehler zu sein.
Jedenfalls hab ich die Testdatei dennoch euch mitgeschickt (20 MByte).

MfG
Loko
Benutzeravatar
Tobias
Programmierer
Beiträge: 889
Registriert: 31.03.2008, 22:59

Beitrag von Tobias » 26.05.2011, 14:04

Hallo Loko444,

ich habe mir eben deine Support-Anfrage angesehen.
Der Sender verpackt die Audio-Pakete leider nicht ganz DVB-Konform.

Mit der akutellen Vorab-Version habe ich zwar schon versucht, dass ganze in einigen Variationen zu kompensieren aber es klappt nicht immer.

Daher wirst du bei diesem Sender aktuell beim Demux, MPEG-PS und DVD-Export Probleme haben.

Wir werden prüfen, ob wir das Programm soweit anpassen können, dass dieser Sender auch voll unterstützt werden können. Dies werden wir aber nur machen, wenn dadurch nicht die gesamte Stabilität drunter leidet.
Diese Änderung würde eine sehr kritische Code stelle betreffen.
MfG
Tobias
Loko444
Beiträge: 8
Registriert: 23.05.2011, 22:27

Beitrag von Loko444 » 26.05.2011, 14:47

Tobias hat geschrieben:Hallo Loko444,

ich habe mir eben deine Support-Anfrage angesehen.
Der Sender verpackt die Audio-Pakete leider nicht ganz DVB-Konform.

Mit der akutellen Vorab-Version habe ich zwar schon versucht, dass ganze in einigen Variationen zu kompensieren aber es klappt nicht immer.

Daher wirst du bei diesem Sender aktuell beim Demux, MPEG-PS und DVD-Export Probleme haben.

Wir werden prüfen, ob wir das Programm soweit anpassen können, dass dieser Sender auch voll unterstützt werden können. Dies werden wir aber nur machen, wenn dadurch nicht die gesamte Stabilität drunter leidet.
Diese Änderung würde eine sehr kritische Code stelle betreffen.
Besten Dank für die rasche und die sehr kompetente Antwort, auch wenn diese Antwort ad hoc mein Problem - aus verständlichen Gründen - nicht löst.

Jedenfalls hab ich jetzt Gewissheit, dass das Problem von mir vorerst nicht gelöst werden kann, und ich mir so sehr viel Test-Zeit ersparen.

Wäre natürlich sehr schön, wenn in einer zukünftigen Version dieses Anliegen in einer neuen Softwareversion gelöst würde.

Viele Grüße und nochmals besten Dank
Loko
Benutzeravatar
Ralf
Inhaber HS
Beiträge: 10438
Registriert: 13.08.2005, 15:23

Re: Englischen TS-Stream in mpeg konvertiert - kein Ton!

Beitrag von Ralf » 12.10.2011, 16:31

Hallo Loko444,

bitte prüfe mal diesen Sender mit der Version 2.20. Sollte gelöst sein.
Mit freundlichen Grüßen

Ralf

Gehe zu Facebook...
Über ein “Like” würden wir uns sehr freuen.
Bild
Antworten

Zurück zu „MPEG2“