Fehlermarkierung wird gelöscht

Antworten
bop99
Beiträge: 16
Registriert: 24.10.2005, 21:07

Fehlermarkierung wird gelöscht

Beitrag von bop99 » 10.09.2011, 05:55

In einem anderem Posting, leider bisher ohne Antwort, hatte ich bereits geschrieben, dass die Konvertierung in MPEG nicht sauber funktioniert, wenn das Ausgangsmaterial Fehler in der Video- oder Tonspur hat. Bei mir sind es Fehler in der Tonspur. Die erzeugt der Technisat HDS2 offenbar bei laufender Aufzeichnung, wenn dann eine zweite Aufzeichnung dazu geschaltet wird. Der Schaltvorgang scheint die Fehlerquelle zu sein.

Wenn ich jetzt DVR-Studio nach Fehler suchen lasse, wäre schön wenn das DVR-Studio automatisch machen würde, wird ein Fehler in der Audiospur festgestellt.

Dieser ist dann auch in der Liste rechts neben dem Videofenster zu sehen.
Wenn ich jetzt die separate AC3.0-Tonspur im Ausgangsmaterial deaktiviere, dann wird auch die Fehlerstelle gelöscht.

Wenn nun das Rohmaterial in MPEG gewandelt wird, dann wird im Meldefenster wieder der Tonfehler gefunden.

Ab dem Tonfehler ist die Ausgabe stumm.

Bitte keinen Hinweis auf den KM-Player. Erstens ist das Teil ziemlich sonderbar und zweitens sollte das Ergebnis, also das MPEG-File mit herkömmlicher Software (Windows Media Player, Classic Player, VLC, Power-DVD oder MCE oder Mediaportal) abspielbar sein und zwar ohne Tonverlust.

Leider ist das aber nicht der Fall.

Nochmals der Hinweis:
Wenn die .TS-Datei in M2TS gewandelt wird, ist ein Fehler in der Ton- oder Audiospur überhaupt kein Problem. Der Fehler wird mitkopiert und das File ist einwandfrei abspielbar.

Leider ist hier nur das Problem, dass der divx-Konverter, der das File eindampfen soll (1,4 GByte für 1 Stunde Spielzeit ist mir zuviel) mit M2TS nicht klar kommt.

Die Konvertierung muss also nach MPEG erfolgen.

Leider habe ich den Eindruck, dass DVR-Studio hier mit Ton- und Videofehlern ein Problem hat.
Benutzeravatar
Ralf
Inhaber HS
Beiträge: 10459
Registriert: 13.08.2005, 15:23

Beitrag von Ralf » 10.09.2011, 09:20

Hallo bop99,

die Erzeugung des MPE2 Exports wird über ein nicht von uns entwickeltes Programmteil gemacht, dass leider sehr Anfällig auf Fehlerstellen reagiert.

Hier was eigenes zu entwickeln, wäre extrem aufwendig.
Es ist auch nicht gesagt, dass es nur ein Audiofehler ist. Bei der Unterscheidung Audio oder Video Fehler wird nur das ERTSMALIG betroffenen Datenpaket genommen. Da diese Datenpakete verschachtet im Stream sind ist ab einer gewissen Größe der Störung auch immer das Video betroffen, obwohl dort der rote Strich noch nicht erscheint.

Wir sind dabei zu prüfen, Endoder einzukaufen. Wenn das kommt ist es auch möglich den Stream komplett zu zerlegen und neu Normgerecht aufzubauen. Somit sind dann auch solche Fehlerstellen weg.
Mit freundlichen Grüßen

Ralf

Gehe zu Facebook...
Über ein “Like” würden wir uns sehr freuen.
Bild
Antworten

Zurück zu „MPEG2“